Payouts toward Knab Bank
Incident Report for Zettle Status Page
Resolved
Every merchant with a KNAB bank account should have received all their payouts. if not please contact our support team.
Posted Apr 18, 2024 - 09:17 UTC
Update
We can confirm the payouts have left our bank. but we are still investigating to see where the issue is
Posted Apr 16, 2024 - 14:38 UTC
Investigating
Payouts made to our merchants with a KNAB Bank account have not been received we are currently investigating the issue. Please make sure to contact your bank regarding this.
Posted Apr 16, 2024 - 07:46 UTC
This incident affected: Netherlands.