UK merchants not seeing payouts
Incident Report for Zettle Status Page
Resolved
All merchants should now see the payouts in their accounts.
Posted Apr 22, 2024 - 16:16 UTC
Monitoring
We are seeing the payouts come through and are monitoring the situation.
Posted Apr 22, 2024 - 15:27 UTC
Investigating
We are currently experiencing issues with some UK merchants not seeing their last Zettle payouts in their wallet. We are investigating.
Posted Apr 22, 2024 - 14:36 UTC
This incident affected: UK.